[3/5] Don't bootstrap GCC with -mcet

Message ID 20180422134825.7165-4-hjl.tools@gmail.com
State New
Headers show
Series
  • x86/CET: Remove the -mcet command-lint option
Related show

Commit Message

H.J. Lu April 22, 2018, 1:48 p.m.
With revision 259496:

commit b1384095a7c1d06a44b70853372ebe037b2f7867
Author: hjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>
Date:   Thu Apr 19 15:15:04 2018 +0000

    x86: Enable -fcf-protection with multi-byte NOPs

-fcf-protection no longer requires -mcet.

config/

	PR target/85485
	* bootstrap-cet.mk (STAGE2_CFLAGS): Remove -mcet.
	(STAGE3_CFLAGS): Likewise.

gcc/

	PR target/85485
	* doc/install.texi: Remove -mcet from bootstrap-cet.
---
 config/bootstrap-cet.mk | 6 +++---
 gcc/doc/install.texi    | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)

-- 
2.14.3

Patch

diff --git a/config/bootstrap-cet.mk b/config/bootstrap-cet.mk
index f09193a6dea..b5dee601a3f 100644
--- a/config/bootstrap-cet.mk
+++ b/config/bootstrap-cet.mk
@@ -1,4 +1,4 @@ 
-# This option enables -fcf-protection -mcet for stage2 and stage3.
+# This option enables -fcf-protection for stage2 and stage3.
 
-STAGE2_CFLAGS += -fcf-protection -mcet
-STAGE3_CFLAGS += -fcf-protection -mcet
+STAGE2_CFLAGS += -fcf-protection
+STAGE3_CFLAGS += -fcf-protection
diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
index 73030a2281a..511e146f023 100644
--- a/gcc/doc/install.texi
+++ b/gcc/doc/install.texi
@@ -2519,7 +2519,7 @@  must be used along with @code{bootstrap-debug-lean} and
 @item @samp{bootstrap-cet}
 This option enables Intel CET for host tools during bootstrapping.
 @samp{BUILD_CONFIG=bootstrap-cet} is equivalent to adding
-@option{-fcf-protection -mcet} to @samp{BOOT_CFLAGS}.  This option
+@option{-fcf-protection} to @samp{BOOT_CFLAGS}.  This option
 assumes that the host supports Intel CET (e.g. GNU assembler version
 2.30 or later).