Use binutils 2.35 branch in build-many-glibcs.py

Message ID alpine.DEB.2.21.2007242038410.3345@digraph.polyomino.org.uk
State New
Headers show
Series
  • Use binutils 2.35 branch in build-many-glibcs.py
Related show

Commit Message

Joseph Myers July 24, 2020, 8:39 p.m.
This patch makes build-many-glibcs.py use binutils 2.35 branch.

Tested with build-many-glibcs.py (compilers and glibcs builds).


-- 
Joseph S. Myers
joseph@codesourcery.com

Comments

Vitaly Buka via Libc-alpha July 27, 2020, 1:07 p.m. | #1
* Joseph Myers:

> This patch makes build-many-glibcs.py use binutils 2.35 branch.

>

> Tested with build-many-glibcs.py (compilers and glibcs builds).

>

> diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py

> index f17a8a250d..efd9a9e6dc 100755

> --- a/scripts/build-many-glibcs.py

> +++ b/scripts/build-many-glibcs.py

> @@ -747,7 +747,7 @@ class Context(object):

>  

>      def checkout(self, versions):

>          """Check out the desired component versions."""

> -        default_versions = {'binutils': 'vcs-2.34',

> +        default_versions = {'binutils': 'vcs-2.35',

>                              'gcc': 'vcs-10',

>                              'glibc': 'vcs-mainline',

>                              'gmp': '6.2.0',


I double-checked that this does not lead to new build failures, and the
built binaries on x86_64-linux-gnu and i686-linux-gnu appear to be okay.
This should impact release testing, so I think it's okay for glibc 2.32.

Thanks,
Florian

Patch

diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py
index f17a8a250d..efd9a9e6dc 100755
--- a/scripts/build-many-glibcs.py
+++ b/scripts/build-many-glibcs.py
@@ -747,7 +747,7 @@  class Context(object):
 
     def checkout(self, versions):
         """Check out the desired component versions."""
-        default_versions = {'binutils': 'vcs-2.34',
+        default_versions = {'binutils': 'vcs-2.35',
                             'gcc': 'vcs-10',
                             'glibc': 'vcs-mainline',
                             'gmp': '6.2.0',