Obsolete PowerPC PE, winnt and cygwin targets

Message ID 20200615053923.GB10692@bubble.grove.modra.org
State New
Headers show
Series
  • Obsolete PowerPC PE, winnt and cygwin targets
Related show

Commit Message

Cui, Lili via Binutils June 15, 2020, 5:39 a.m.
The PowerPC PE support is so old and bitrotted that it ought to be
removed.  Test results for a cross from x86_64 with no C cross
compiler currently shows 109 fails.  I don't think anyone cares about
the target.

This FIXME in bfd/peXXigen.c has been around since 1999, git commit
277d1b5e453:

/* FIXME: This file has various tests of POWERPC_LE_PE.  Those tests
   worked when the code was in peicode.h, but no longer work now that
   the code is in peigen.c.  PowerPC NT is said to be dead.  If
   anybody wants to revive the code, you will have to figure out how
   to handle those issues.  */

and this one in gas/config/tc-ppc.c since 1995, git commit
cd557d83d61:

 * FIXME: I just noticed this. This doesn't work at all really. It it
 *        setting bits that bfd probably neither understands or uses. The
 *        correct approach (?) will have to incorporate extra fields attached
 *        to the section to hold the system specific stuff. (krk)

	* config.bfd: Obsolete powerpcle-*-pe targets.


-- 
Alan Modra
Australia Development Lab, IBM

Patch

diff --git a/bfd/config.bfd b/bfd/config.bfd
index 40f259c92a..231e6f155d 100644
--- a/bfd/config.bfd
+++ b/bfd/config.bfd
@@ -53,6 +53,7 @@  case $targ in
     echo "*** Use or1k-*-elf or or1k-*-linux as the target instead" >&2
     exit 1
     ;;
+ powerpcle-*-pe | powerpcle-*-winnt* | powerpcle-*-cygwin* | \
  null)
     if test "x$enable_obsolete" != xyes; then
       echo "*** Configuration $targ is obsolete." >&2