[wwwdocs] GCC 10: Document RISC-V target's requirement for binutils 2.30

Message ID alpine.LFD.2.21.2004021533460.461@redsun52.ssa.fujisawa.hgst.com
State New
Headers show
Series
  • [wwwdocs] GCC 10: Document RISC-V target's requirement for binutils 2.30
Related show

Commit Message

Iain Buclaw via Gcc-patches April 2, 2020, 2:50 p.m.
Match GCC commit bfe78b08471f ("RISC-V: Using fmv.x.w/fmv.w.x rather 
than fmv.x.s/fmv.s.x") and commit 879bc686a0aa ("doc: RISC-V: Update 
binutils requirement to 2.30").
---
Hi,

 OK to apply?

  Maciej
---
 htdocs/gcc-10/changes.html | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Iain Buclaw via Gcc-patches April 9, 2020, 1:42 p.m. | #1
On Thu, 2 Apr 2020, Maciej W. Rozycki wrote:

> Match GCC commit bfe78b08471f ("RISC-V: Using fmv.x.w/fmv.w.x rather 

> than fmv.x.s/fmv.s.x") and commit 879bc686a0aa ("doc: RISC-V: Update 

> binutils requirement to 2.30").


 Ping for:

<https://gcc.gnu.org/pipermail/gcc-patches/2020-April/543144.html>

  Maciej
Iain Buclaw via Gcc-patches April 9, 2020, 1:59 p.m. | #2
On Thu, 2020-04-09 at 14:42 +0100, Maciej W. Rozycki via Gcc-patches wrote:
> On Thu, 2 Apr 2020, Maciej W. Rozycki wrote:

> 

> > Match GCC commit bfe78b08471f ("RISC-V: Using fmv.x.w/fmv.w.x rather 

> > than fmv.x.s/fmv.s.x") and commit 879bc686a0aa ("doc: RISC-V: Update 

> > binutils requirement to 2.30").

> 

>  Ping for:

> 

> <https://gcc.gnu.org/pipermail/gcc-patches/2020-April/543144.html>

OK.  Do we need any configure magic to detect what assembler version is being
used and warn/error if it's too old?

jeff
Iain Buclaw via Gcc-patches April 9, 2020, 2:36 p.m. | #3
On Thu, 9 Apr 2020, Jeff Law wrote:

> > > Match GCC commit bfe78b08471f ("RISC-V: Using fmv.x.w/fmv.w.x rather 

> > > than fmv.x.s/fmv.s.x") and commit 879bc686a0aa ("doc: RISC-V: Update 

> > > binutils requirement to 2.30").

> > 

> >  Ping for:

> > 

> > <https://gcc.gnu.org/pipermail/gcc-patches/2020-April/543144.html>

> OK.  Do we need any configure magic to detect what assembler version is being

> used and warn/error if it's too old?


 I discussed this with Jim (cc-ed) who thinks there is no need for that; 
cf. <https://gcc.gnu.org/pipermail/gcc-patches/2020-March/542280.html>.

 Patch now applied, thanks for your review.

  Maciej
Iain Buclaw via Gcc-patches April 9, 2020, 2:40 p.m. | #4
On Thu, 2020-04-09 at 15:36 +0100, Maciej W. Rozycki wrote:
> On Thu, 9 Apr 2020, Jeff Law wrote:

> 

> > > > Match GCC commit bfe78b08471f ("RISC-V: Using fmv.x.w/fmv.w.x rather 

> > > > than fmv.x.s/fmv.s.x") and commit 879bc686a0aa ("doc: RISC-V: Update 

> > > > binutils requirement to 2.30").

> > > 

> > >  Ping for:

> > > 

> > > <https://gcc.gnu.org/pipermail/gcc-patches/2020-April/543144.html>

> > OK.  Do we need any configure magic to detect what assembler version is being

> > used and warn/error if it's too old?

> 

>  I discussed this with Jim (cc-ed) who thinks there is no need for that; 

> cf. <https://gcc.gnu.org/pipermail/gcc-patches/2020-March/542280.html>;.

Great thanks. 

JEff

Patch

diff --git a/htdocs/gcc-10/changes.html b/htdocs/gcc-10/changes.html
index 3d8e0ba9..809bbb4d 100644
--- a/htdocs/gcc-10/changes.html
+++ b/htdocs/gcc-10/changes.html
@@ -725,7 +725,13 @@  a work-in-progress.</p>
   </li>
 </ul>
 
-<!-- <h3 id="riscv">RISC-V</h3> -->
+<h3 id="riscv">RISC-V</h3>
+<ul>
+  <li>
+    The <code>riscv*-*-*</code> targets now require GNU binutils version 2.30
+    or later, to support new assembly instructions produced by GCC.
+  </li>
+</ul>
 
 <!-- <h3 id="rx">RX</h3> -->