[OBVIOUS,GCC9] Do not use -Werror in a test that has -frepo warning (PR testsuite/91175).

Message ID 3b726616-7205-48f1-b8f9-0449b58597fd@suse.cz
State New
Headers show
Series
  • [OBVIOUS,GCC9] Do not use -Werror in a test that has -frepo warning (PR testsuite/91175).
Related show

Commit Message

Martin Liška July 16, 2019, 10:20 a.m.
Hi.

This is fix of the fallout caused by the warning for -frepo.
I've just tested the test locally and I'm going to install the patch.

Thanks,
Martin

gcc/testsuite/ChangeLog:

2019-07-16  Martin Liska  <mliska@suse.cz>

	PR testsuite/91175
	* g++.old-deja/g++.pt/instantiate4.C: Do not use -Werror.
---
 gcc/testsuite/g++.old-deja/g++.pt/instantiate4.C | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/gcc/testsuite/g++.old-deja/g++.pt/instantiate4.C b/gcc/testsuite/g++.old-deja/g++.pt/instantiate4.C
index 97838689d38..071a64be441 100644
--- a/gcc/testsuite/g++.old-deja/g++.pt/instantiate4.C
+++ b/gcc/testsuite/g++.old-deja/g++.pt/instantiate4.C
@@ -1,8 +1,8 @@ 
 // { dg-do link }
-// { dg-options "-frepo -Werror" }
+// { dg-options "-frepo" }
 // { dg-require-host-local "" }
 // { dg-skip-if "dkms are not final links" { vxworks_kernel } }
-// { dg-error "is deprecated and will be removed in a future release" "" { target *-*-* } 0 }
+// { dg-warning "is deprecated and will be removed in a future release" "" { target *-*-* } 0 }
 
 
 // Submitted by Melissa O'Neill <oneill@cs.sfu.ca>