Committed: arm-dis.c (print_insn_coprocessor): Rename index to index_operand.

Message ID alpine.BSF.2.20.16.1907101244370.86401@arjuna.pair.com
State New
Headers show
Series
  • Committed: arm-dis.c (print_insn_coprocessor): Rename index to index_operand.
Related show

Commit Message

Hans-Peter Nilsson July 10, 2019, 4:46 p.m.
Older gcc warns, arguably incorrectly, about name collisions between
global functions and function-local variable names.  Consesus has been
to rename local variables whenever this is spotted, hence committed as
obvious.  Note the pre-existing variable named "idx"; "index_operand"
seemed logical given the context.

opcodes:
	* arm-dis.c (print_insn_coprocessor): Rename index to
	index_operand.

Patch

diff --git a/opcodes/arm-dis.c b/opcodes/arm-dis.c
index 03aebb5..f3b1cc3 100644
--- a/opcodes/arm-dis.c
+++ b/opcodes/arm-dis.c
@@ -6767,23 +6767,23 @@  print_mve_vmov_index (struct disassemble_info *info, unsigned long given)
   unsigned long op1 = arm_decode_field (given, 21, 22);
   unsigned long op2 = arm_decode_field (given, 5, 6);
   unsigned long h = arm_decode_field (given, 16, 16);
-  unsigned long index, esize, targetBeat, idx;
+  unsigned long index_operand, esize, targetBeat, idx;
   void *stream = info->stream;
   fprintf_ftype func = info->fprintf_func;

   if ((op1 & 0x2) == 0x2)
     {
-      index = op2;
+      index_operand = op2;
       esize = 8;
     }
   else if (((op1 & 0x2) == 0x0) && ((op2 & 0x1) == 0x1))
     {
-      index = op2  >> 1;
+      index_operand = op2  >> 1;
       esize = 16;
     }
   else if (((op1 & 0x2) == 0) && ((op2 & 0x3) == 0))
     {
-      index = 0;
+      index_operand = 0;
       esize = 32;
     }
   else
@@ -6793,7 +6793,7 @@  print_mve_vmov_index (struct disassemble_info *info, unsigned long given)
     }

   targetBeat =  (op1 & 0x1) | (h << 1);
-  idx = index + targetBeat * (32/esize);
+  idx = index_operand + targetBeat * (32/esize);

   func (stream, "%lu", idx);
 }