Use GCC 9 in build-many-glibcs.py [committed]

Message ID alpine.DEB.2.21.1905071446370.3445@digraph.polyomino.org.uk
State New
Headers show
Series
  • Use GCC 9 in build-many-glibcs.py [committed]
Related show

Commit Message

Joseph Myers May 7, 2019, 2:46 p.m.
Committed.


-- 
Joseph S. Myers
joseph@codesourcery.com

Patch

diff --git a/ChangeLog b/ChangeLog
index c71f249125..1ddb948fa8 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@ 
+2019-05-07  Joseph Myers  <joseph@codesourcery.com>
+
+	* scripts/build-many-glibcs.py (Context.checkout): Default GCC
+	version to 9 branch.
+
 2019-05-03  Anton Youdkevitch  <anton.youdkevitch@bell-sw.com>
 
 	* sysdeps/aarch64/multiarch/ifunc-impl-list.c: Added
diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py
index fd811af9b3..6f9a35331f 100755
--- a/scripts/build-many-glibcs.py
+++ b/scripts/build-many-glibcs.py
@@ -711,7 +711,7 @@  class Context(object):
     def checkout(self, versions):
         """Check out the desired component versions."""
         default_versions = {'binutils': 'vcs-2.32',
-                            'gcc': 'vcs-8',
+                            'gcc': 'vcs-9',
                             'glibc': 'vcs-mainline',
                             'gmp': '6.1.2',
                             'linux': '5.0',